Quickcharge - Software Deployment Maintenance
Maintenance
in progress
3 hours 2 minutes
2026-06-25T22:00:00.0000000Z
Quickcharge - Software Deployment Maintenance
Status: in progress
Start:
2026-06-25T22:00:00.0000000Z
Estimated Duration: 480 minutes
Affected Components:
Quickcharge
US1
US2
US3
US4
US5
US6
US7
US101
US102
File Transfer Servers
Just Walk Out for Quickcharge
Update
2026-06-25T22:00:00.0000000Z
2026-06-25T22:00:00.0000000Z
We're pleased to announce that Quickcharge will be deploying a fix on the evening of June 25th, 2026.
Please check your Back Office system for an in-app message to determine if your site is included in this deployment wave.
For additional questions, feel free to contact our Support Team 844-766-4435
Thank you for being a valued Quickcharge customer,
The Quickcharge Team