BitBucket Site fails to Load

Informational

BitBucket Site fails to Load

Status: closed
Date:
End:
Duration: 2 hours 28 minutes
Affected Components:
Monitoring

Some customers experienced intermittent errors when accessing Bitbucket Cloud, including failures loading the site and associated impacts to Pipelines. We have been able to apply the fix to mitigate the issues and we are seeing recovery. We continue to monitor the situation and should be fully recovered soon. We should be able to provide more updates in the next one hour or earlier.

Monitoring

A fix has been implemented and services are operating normally for all affected customers. We are continuing to monitor to confirm stability. We will provide a further update within 60 minutes.

Resolved

On July 31, 2026, affected Bitbucket Cloud users for some customers may have experienced failures loading the site and impacts to associated pipelines. The issue has now been resolved, and the service is operating normally for all affected customers.