Illumia Payments - Credit Card Processing - Vantiv

Incident

Illumia Payments - Credit Card Processing - Vantiv

Status: closed
Start:
End:
Duration: 54 minutes
Affected Components:
Illumia Payments Credit Card Processing
Update

Illumia Payments is currently experiencing issues processing credit card payments through Vantiv. This only impacts campuses that use Vantiv as their credit card processor. Other processors and payments processed through SmartPay are not impacted.

Resolved

This incident has been resolved and all systems are now operating normally.